PDA

View Full Version : New to me Weber Q200



swamprb
08-14-2012, 06:52 PM
Picked up a 5 year old Weber Q200, cover, full 5 gallon LP tank and adapter hose for $30! Guy said it wasn't heating up like it used to and thought it needed a regulator?

http://i163.photobucket.com/albums/t310/swamprb/Ugly%20Drum%20Smoker/Weber/IMG_5440.jpg

Gave it a thorough cleaning and took the time to get the burner tube looking good again, it fired up on the first strike! I did notice the flames were not adjusting, so I removed the hose and purged the regulator, let it sit for 10 minutes, reattached the hose, turned the burner knob to light and opened the tank very slowly and fired it up and it worked like new again!

Grilled Pineapple, Dales marinated boneless thighs and Polenta slices.

http://i163.photobucket.com/albums/t310/swamprb/Ugly%20Drum%20Smoker/Weber/IMG_5455.jpg

Wagyu tenderloin medallions marinated in Dales sauce with a Dalmation rub.

http://i163.photobucket.com/albums/t310/swamprb/Ugly%20Drum%20Smoker/Weber/IMG_5448.jpg

http://i163.photobucket.com/albums/t310/swamprb/Ugly%20Drum%20Smoker/Weber/IMG_5449.jpg

Buzzwinder
08-14-2012, 07:21 PM
Nice :thumbs up:

SmokyOkie
08-14-2012, 08:16 PM
Not bad at all for a gasser.

Very nice indeed and a steal on the grill for sure!:thumbs up::thumbs up:

tomshoots
08-14-2012, 09:47 PM
Good deal! Better chow!! :thumbs up::thumbs up:

Bubblehead
08-15-2012, 03:24 PM
Great score!!!:thumbs up::thumbs up:

I had one in Hawaii and picked up another here in OKC after I retired, great little gasser.

O B City
08-17-2012, 11:08 PM
I did notice the flames were not adjusting, so I removed the hose and purged the regulator, let it sit for 10 minutes, reattached the hose, turned the burner knob to light and opened the tank very slowly and fired it up and it worked like new again!


I have had the next size up for a few years, and noticed the same behavior. Please tell me more about how to "purge the regulator" . Thanks in advance.

PigCicles
08-18-2012, 08:43 AM
Great score buster! And it puts out some excellent eats too. Congrats on the excellent find :thumbs up:

Bubblehead
08-18-2012, 11:24 AM
I have had the next size up for a few years, and noticed the same behavior. Please tell me more about how to "purge the regulator" . Thanks in advance.


I've had to reset mine a few times over the years. Typically just disconnecting and reconnecting the propane does the trick for me.

Curtzo
02-26-2013, 12:05 AM
Great find... These are great little grills!

I had one years ago that my neighbor gave to me that he and his wife used camping. I think I used it for about three or four years.

My in-laws now use it for their camper and still works great. Had the same issue not heating up, but a quick disconnect and connection did the trick.

Enjoy it!

CM